Korjaa virhe: PHP-asennuksesta puuttuu WordPressin vaadittava MySQL-laajennus

"Vaikuttaa siltä, ​​että PHP-asennuksesta puuttuu WordPressin vaadittava MySQL-laajennus”Onko virhe, jonka monet blogien ja verkkosivustojen omistajat ovat havainneet WordPress.
Tämä ei ole huolestuttavaa. MySQL-laajennuksen puute PHP: ltä on tyypillistä tyhjästä asennetuille käyttöjärjestelmille, VPS: lle tai erillisille palvelimille, joissa PHP-laajennukset eivät olleet osa asennuspakettia. Tämä ongelma esiintyy molemmissa Ubuntu ja CentOS. Tässä tilanteessa ongelma ratkaistaan ​​yksinkertaisesti PHP-päivityksellä ja moduulin asennuksella "php-mysql".
Päivitä PHP ja asenna MySQL-laajennus Ubuntuun

apt-get update
apt-get install php-mysql

Päivitä PHP ja asenna MySQL-laajennus CentOS: iin

yum update
yum install php70w-mysql

Tämän vaiheen jälkeen käynnistä Apache-palvelu uudelleen tai nginx.

Tapasin myös skenaarion, jossa vaikka MySQL-laajennus on olemassa PHP: ssä, WordPressillä luotu blogi näytti virheen "PHP-asennuksestasi näyttää puuttuvan WordPressin edellyttämä MySQL-laajennus". Suurimman osan ajasta virhe ilmenee WordPressin asennuksessa. Tällä kertaa hän kuitenkin ilmestyi blogissa, joka oli ollut aktiivinen useita vuosia.
Tässä tilanteessa huomasin, että ongelma ei ole PHP-moduuleissa, vaan hyvin vanhassa WordPress-versiossa, joka ei ole enää yhteensopiva PHP 7.4.4RC1: n kanssa. Yksinkertainen WordPress-päivitys uusimpaan versioon ratkaisi virheen.

Korjaa virhe: PHP-asennuksesta puuttuu WordPressin vaadittava MySQL-laajennus

Kirjailijasta

Stealth

Intohimoisesti kaikesta laitteesta ja IT: stä kirjoitan mielihyvin varkainsettings.com vuodesta 2006 ja haluan löytää kanssasi uusia asioita tietokoneista ja käyttöjärjestelmistä macOS, Linux, Windows, iOS ja Android.

Jätä kommentti